[slicer-users] vmtkcenterlines input model loading problem

Daniel Haehn haehn at bwh.harvard.edu
Thu Feb 11 06:24:04 EST 2010


Hi Mohan,

I just checked in a new version of the VMTKCenterlines module. It should be
available within the extension wizard tomorrow. Maybe this fixes your
issues.

If not, i will point you to some debug statements for the python console.

Let me know,
Daniel

On Tue, 9 Feb 2010 20:04:44 +0530, Madan Rao <rao.lms at gmail.com> wrote:
> Hello Daniel,
> 
> Thanks.
> 
> Of course I am selecting the VMTK Evolution Model correctly, but clicking
> the "Prepare model"  button
> has no response, not even in error log.
> 
> There seems some connecting problem with python files..
> 
> Could you recommend some debug queries which I can enter in Python
> Interactor ?
> 
> I use Vista OS, Slicer3 3.5.2010-01-07 and yesterday's VMTK module
library
> and python files.
> 
> AM Mohan Rao
> 
> On Tue, Feb 9, 2010 at 2:43 PM, Daniel Haehn <haehn at bwh.harvard.edu>
> wrote:
> 
>> Hi Mohan,
>>
>> so I tried your model and it works fine for me.
>>
>> Be sure to select it as input model (instead of VMTKCenterlinesPrepOut)
> and
>> then click "Prepare model". The model should turn green afterwards. The
>> preparation step includes some topology enhancements and closes the
> model
>> in- and outlets.
>>
>> Please let me know if you have success.
>>
>> Bye,
>> Daniel
>>
>> On Tue, 9 Feb 2010 12:44:59 +0530, Madan Rao <rao.lms at gmail.com> wrote:
>> > Hello Daniel,
>> >
>> > Thanks.
>> >
>> > Yes, I tried loading the model separately and is able to load it as
> input
>> > for vmtkcenterlines module. But when
>> > I click Prepare Model button nothing happens.
>> >
>> > I am attaching the VMTK Evolution Model.vtk here.
>> >
>> > AM Mohan Rao
>> >
>> >
>> >
>> > On Tue, Feb 9, 2010 at 3:06 AM, Daniel Haehn <haehn at bwh.harvard.edu>
>> > wrote:
>> >
>> >> Hi Mohan,
>> >>
>> >> this is a strange error. So you say when you click the model selector
> in
>> >> the panel "Input", it does not show the models at all? They appear in
>> >> the models module? Maybe saving the Vmtkevolutionmodel and then
> exiting
>> >> slicer and loading it will work? Once you are at this stage of the
>> >> processing pipeline, you only need this model to compute the
>> >> centerlines.
>> >>
>> >> Bye,
>> >> Daniel
>> >>
>> >> On Sat, 2010-02-06 at 14:02 +0530, Madan Rao wrote:
>> >> > Hello,
>> >> >
>> >> > I am using vmtkslicermodule on a sample CTA of coronaries following
>> >> > Daniel Hahn's instructions. I am able to
>> >> > work successfully upto levelsetsegmentation to generate the
>> >> > vmtkevolutionmodel.
>> >> >
>> >> > However, I am unable to run vmtkcenterlines because input model
> button
>> >> > is not able to show options.
>> >> >
>> >> > In the error log I find:
>> >> >
>> >> > ERROR: In ..\..\VTK\IO\vtkWriter.cxx, line 79
>> >> > vtkPolyDataWriter (16249D58): No input provided!
>> >> >
>> >> >
>> >> > ERROR: In ..\KWWidgets\vtkKWApplication.cxx, line 1288
>> >> > vtkSlicerApplication (06809CE0): TclTk error: invalid command name
>> >> > "vtkObj6240"
>> >> > invalid command name "vtkObj6240"
>> >> >     while executing
>> >> > "vtkObj6240 UpdateMenu"
>> >> >     (command bound to event)
>> >> >
>> >> >
>> >> > ERROR: In ..\..\..\Slicer3\Libs\vtkITK
>> >> > \vtkITKArchetypeImageSeriesReader.cxx, line 1005
>> >> > vtkITKArchetypeImageSeriesReader (0C6267A8): The subclass has not
>> >> > defined anything for ExecuteData!
>> >> >
>> >> >
>> >> > Thanks.
>> >> >
>> >> > AM Mohan Rao
>> >> >
>> >> > _______________________________________________
>> >> > slicer-users mailing list
>> >> > slicer-users at bwh.harvard.edu
>> >> > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> >> > To unsubscribe: send email to
>> >> slicer-users-request at massmail.spl.harvard.edu with unsubscribe as the
>> >> subject
>> >>
>> >>
>>
>>




More information about the slicer-users mailing list