[slicer-users] MRIBiasFieldCorrection

Sylvain Jaume sylvain at csail.mit.edu
Fri Mar 19 07:31:38 EDT 2010


Hi Madan,

I was still developing the MRIBiasFieldCorrection after Jan 7. I
believe I added the executable after the Jan 7 release. In case the
executable is not built, you can replace the CMakeLists.txt with the
new one.

Regards,
Sylvain

On Fri, Mar 19, 2010 at 1:07 AM, Madan Rao <rao.lms at gmail.com> wrote:
> Hello Sylvain,
>
> Thanks.
>
> I have no problems with the Slicer3-build in cygwin regarding
> MRIBiasFieldCorrection.exe.
>
> What I am interested is the exe in Slicer3 3.5-2010-01-07 in which the
> MRIBiasFieldCorrection module works,
> (since there is no MRIBiasFieldCorrection.exe in Slicer3 3.5.2010-01-07).
>
> Sorry for the mix up.
>
> AM Mohan Rao
>
> On Fri, Mar 19, 2010 at 5:02 AM, Sylvain Jaume <sylvain at csail.mit.edu>
> wrote:
>>
>> Hi Madan,
>>
>> You should find the MRIBiasFieldCorrection executable in:
>>
>> ./Slicer3-build/lib/Slicer3/Plugins/
>>
>> Note that it is not MRIFieldCorrection (as you mentioned), but
>> MRIBiasFieldCorrection (in case you were looking at a different
>> executable).
>>
>> I checked on Mac and the executable is correctly built. You can see
>> the add_executable command in the CMakeLists.txt for
>> MRIBiasFieldCorrection. I don't have cygwin, so I cannot test it.
>> Maybe someone building Slicer on cygwin could check if the executable
>> is built?
>>
>> HTH.
>> Sylvain
>>
>> On Thu, Mar 18, 2010 at 11:51 AM, Madan Rao <rao.lms at gmail.com> wrote:
>> > Hello Sylvain,
>> >
>> > Thanks.
>> >
>> > What I meant is:
>> >
>> > (1). I can do MRIBiasFieldCorrection in Slicer3 3.5-2010-01-07 but it
>> > does
>> > not have a MRIBiasFieldCorrection.exe.
>> >
>> > (2). I cannot run the same in Slicer3-build in my cygwin but it has the
>> > exe
>> > in /lib/slicer3/plugins/debug.
>> >
>> > I want to know what exe is involved in MRIFieldCorrection in Slicer3
>> > 3.5.2010-01-07.
>> >
>> > AM Mohan Rao
>> >
>> > On Thu, Mar 18, 2010 at 7:26 PM, Sylvain Jaume <sylvain at csail.mit.edu>
>> > wrote:
>> >>
>> >> Hi Madan,
>> >>
>> >> What do you mean by 'There is no equivalent of
>> >> MRIBiasFieldCorrection.exe in Slicer3 3.5.2010-01-07' ?
>> >> Are you saying that you found the executable in the Jan 7 release and
>> >> you can't find it in the nightly build?
>> >>
>> >> Sylvain
>> >>
>> >> On Thu, Mar 18, 2010 at 4:48 AM, Madan Rao <rao.lms at gmail.com> wrote:
>> >> > Hello all,
>> >> >
>> >> > I want to know which *.exe is used for the MRIBiasFieldCorrection
>> >> > module
>> >> > in
>> >> > Slicer3 3.5.2010-01-07.
>> >> >
>> >> > I used MRIBiasFieldCorrection module in Slicer3 3.5.2010-01-07
>> >> > without
>> >> > any
>> >> > problems.
>> >> > The same in latest Slicer3-build does not work.
>> >> >
>> >> > There is no equivalent of MRIBiasFieldCorrection.exe in Slicer3
>> >> > 3.5.2010-01-07.
>> >> >
>> >> > AM Mohan Rao
>> >> >
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > slicer-users mailing list
>> >> > slicer-users at bwh.harvard.edu
>> >> > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> >> > To unsubscribe: send email to
>> >> > slicer-users-request at massmail.spl.harvard.edu
>> >> > with unsubscribe as the subject
>> >> >
>> >
>> >
>> > _______________________________________________
>> > slicer-users mailing list
>> > slicer-users at bwh.harvard.edu
>> > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> > To unsubscribe: send email to
>> > slicer-users-request at massmail.spl.harvard.edu
>> > with unsubscribe as the subject
>> >
>
>
> _______________________________________________
> slicer-users mailing list
> slicer-users at bwh.harvard.edu
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to slicer-users-request at massmail.spl.harvard.edu
> with unsubscribe as the subject
>



More information about the slicer-users mailing list