[slicer-users] EMSegmentCommandLine errors

Madan Rao rao.lms at gmail.com
Sat Mar 20 04:13:56 EDT 2010


Hello Nicole,

Thanks.

I ran the segmentation CommandLine Module using the example:
EMSegmentTutorialTemplate_ImagesOnly.mrml.

ResultLabelmap:EMtest_label.mhd (an empty mhd file called from result.txt)

targetvolumes: t1.nhdr, t2.nhdr (of old brain atlas),

atlasvolumes:
atlas_background.nhdr
atlas_csf.nhdr
atlas_greymatter.nhdr
atlas_whitematter.nhdr

It runs for some time and ends with the errors which are consistently same.

I am attaching the errors file here.

I ran "processmonitor" of Microsoft and found that it is reading all the
files in the mrml and the libraries,
except few (the target_t2, the t1.nhdr, t2.nhdr).

I use MSVista laptop with 3MB. RAM.

Is it sufficient to run EMSegmentCommandLine module?

AM Mohan Rao


On Tue, Mar 16, 2010 at 8:28 PM, Nicole Aucoin <nicole at bwh.harvard.edu>wrote:

> Hello,
>
> I'd strongly suggest running it once from the Slicer GUI, then looking at
> the Error Log to see the full command line that it passes.
> The mrml scene files end in .mrml and contain node tags that will allow
> slicer to reload the output scene (including volumes).
>
> Nicole
>
> Madan Rao wrote:
>
>> Hello,
>>
>> What is the input for EMSegmentCommandLine atlas data?
>>
>> If I give:
>>
>> Slicer3 --launch EMSegmentCommandLine --mrmlSceneFileName <path to
>> EMSegmentTutorialTemplate.mhd>
>> --resultMRMLSceneFileName <path to segmentation.mhd>
>> --targetVolumeFileNames <path to target_t1_normed.mhd,target_t2_normed.mhd>
>> --atlasVolumeFileNames <path to
>> atlas_background_reg.mhd,atlas_csf_reg.mhd,atlas_greymatter_reg,atlas_whitematter_reg.mhd>
>>
>> I get the error:
>>
>> parameters must already contain an atlas node if you wish to specify atlas
>> volumes..
>>
>> I cannot understand the --parametersMRMLNodeName in this context. If I
>> don't give atlas paths I get the error:
>>
>> No default atlas node is available.
>>
>> Please help.
>>
>> AM Mohan Rao
>>
>> On Tue, Mar 16, 2010 at 6:52 PM, Madan Rao <rao.lms at gmail.com <mailto:
>> rao.lms at gmail.com>> wrote:
>>
>>    Hello Steve,
>>
>>    Thanks. It seems to be working now by following your suggestion.
>>
>>    However, I cant get the --help running from cmd by:
>>
>>    Slicer3 --launch EMSegmentCommandLine --help
>>
>>    Can you explain it?
>>
>>    AM Mohan Rao
>>
>>
>>
>>    On Tue, Mar 16, 2010 at 3:31 PM, Steve Pieper
>>    <pieper at bwh.harvard.edu <mailto:pieper at bwh.harvard.edu>> wrote:
>>
>>        Hi Mohan -
>>
>>        I'm not sure about the color file issue (perhaps Nicole knows).
>>
>>        But for the dll issue you should be able to run a command like:
>>
>>         <path to>/Slicer3.exe --launch EMSegmentCommandLine.exe
>>
>>        this will set up the paths for you so you don't need to copy
>>        anything to the system directories.
>>
>>        Best,
>>        Steve
>>
>>
>>        On M/16/10 3:41 AM, Madan Rao wrote:
>>
>>            Hello all,
>>
>>            I also tried running the exe after creating the path in
>>            the error and
>>            keeping the txt file with no result.
>>
>>            AM Mohan Rao
>>
>>            On Tue, Mar 16, 2010 at 1:03 PM, Madan Rao
>>            <rao.lms at gmail.com <mailto:rao.lms at gmail.com>
>>            <mailto:rao.lms at gmail.com <mailto:rao.lms at gmail.com>>> wrote:
>>
>>               Hello all,
>>
>>               I am trying to run the Segmentation on
>>            EMSegmentCommandLine.exe from
>>               cmd or cygwin on windows vista using the tutorial data.
>>
>>               I get the following error:
>>
>>               ERROR: In
>>
>>  ..\..\..\Slicer3\Libs\MRML\vtkMRMLColorTableStorageNode.cxx,
>>            line 255
>>               vtkMRMLColorTableStorageNode (04C3CE90): ERROR opening
>>            colour file
>>               /home/rao/share/FreeSurfer/FreeSurferColorLUT.txt
>>
>>               I have Slicer3-build using Cygwin. I am able to run the
>>            --help
>>               command from the EMSegmentCommndLine.exe after adding
>>            about 48 *.dll
>>               files
>>               to my system32 library.
>>
>>               Can anyone help please?
>>
>>               AM Mohan Rao
>>
>>
>>
>>
>>
>>            _______________________________________________
>>            slicer-users mailing list
>>            slicer-users at bwh.harvard.edu
>>            <mailto:slicer-users at bwh.harvard.edu>
>>
>>            http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>>            To unsubscribe: send email to
>>            slicer-users-request at massmail.spl.harvard.edu
>>            <mailto:slicer-users-request at massmail.spl.harvard.edu>
>>
>>            with unsubscribe as the subject
>>
>>
>>
>> ------------------------------------------------------------------------
>>
>>
>> _______________________________________________
>> slicer-users mailing list
>> slicer-users at bwh.harvard.edu
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> To unsubscribe: send email to
>> slicer-users-request at massmail.spl.harvard.edu with unsubscribe as the
>> subject
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://massmail.spl.harvard.edu/pipermail/slicer-users/attachments/20100320/9326ef21/attachment.html>
-------------- next part --------------
Type: Error
Time: 03/20/10 13:22:00
Description: ERROR: In ..\..\..\Slicer3\Modules\CommandLineModule\vtkCommandLineModuleLogic.cxx, line 1522
vtkCommandLineModuleLogic (0C13DC38): EMSegment Command-line completed with errors




Type: Error
Time: 03/20/10 13:22:00
Description: ERROR: In ..\..\..\Slicer3\Modules\CommandLineModule\vtkCommandLineModuleLogic.cxx, line 1497
vtkCommandLineModuleLogic (0C13DC38): EMSegment Command-line standard error:

ERROR: no EMSegment parameter nodes in scene.

Errors detetected.  Segmentation failed.





Type: Information
Time: 03/20/10 13:21:37
Description: EMSegment Command-line command line: 

C:/cygwin/home/rao/SLICER~2/lib/Slicer3/Plugins/Debug/EMSegmentCommandLine.exe --mrmlSceneFileName C:/vmtktest/EM/myfiles/Data/EMSegmentTutorialTemplate_ImagesOnly.mrml --resultVolumeFileName C:/segmentation/AutomaticSegmentation/resultlabel/EMtest_label.mhd --targetVolumeFileNames C:/segmentation/AutomaticSegmentation/volumes/target.txt --atlasVolumeFileNames C:/segmentation/AutomaticSegmentation/atlas/atlasvolumes.txt --intermediateResultsDirectory C:/segmentation/AutomaticSegmentation/intermediate_results --resultMRMLSceneFileName C:/segmentation/AutomaticSegmentation/resultmrml/result.mrml 


Type: Information
Time: 03/20/10 13:21:36
Description: CommandLineModule

Type: Information
Time: 03/20/10 13:21:36
Description: C:/cygwin/home/rao/SLICER~2/lib/Slicer3/Plugins/Debug/EMSegmentCommandLine.exe

Type: Information
Time: 03/20/10 13:21:36
Description: Found CommandLine Module, target is 

Type: Warning
Time: 03/20/10 13:08:03
Description: Warning: In ..\..\..\Slicer3\Modules\Measurements\vtkMeasurementsGUI.cxx, line 507
vtkMeasurementsGUI (090F3218): SetActiveViewer: active viewer is NULL, returning.



Type: Error
Time: 03/20/10 12:59:16
Description: ERROR: In ..\..\..\Slicer3\Modules\CommandLineModule\vtkCommandLineModuleLogic.cxx, line 1522
vtkCommandLineModuleLogic (0C13DC38): EMSegment Command-line completed with errors




Type: Error
Time: 03/20/10 12:59:16
Description: ERROR: In ..\..\..\Slicer3\Modules\CommandLineModule\vtkCommandLineModuleLogic.cxx, line 1497
vtkCommandLineModuleLogic (0C13DC38): EMSegment Command-line standard error:

ERROR: no EMSegment parameter nodes in scene.

Errors detetected.  Segmentation failed.





Type: Information
Time: 03/20/10 12:59:05
Description: EMSegment Command-line command line: 

C:/cygwin/home/rao/SLICER~2/lib/Slicer3/Plugins/Debug/EMSegmentCommandLine.exe --mrmlSceneFileName C:/vmtktest/EM/myfiles/Data/EMSegmentTutorialTemplate_ImagesOnly.mrml --resultVolumeFileName C:/segmentation/AutomaticSegmentation/resultlabel/EMtest_label.mhd --targetVolumeFileNames C:/segmentation/AutomaticSegmentation/volumes/target.txt --atlasVolumeFileNames C:/segmentation/AutomaticSegmentation/atlas/atlasvolumes.txt --intermediateResultsDirectory C:/segmentation/AutomaticSegmentation/intermediate_results 


Type: Information
Time: 03/20/10 12:59:05
Description: CommandLineModule

Type: Information
Time: 03/20/10 12:59:05
Description: C:/cygwin/home/rao/SLICER~2/lib/Slicer3/Plugins/Debug/EMSegmentCommandLine.exe

Type: Information
Time: 03/20/10 12:59:05
Description: Found CommandLine Module, target is 

Type: Error
Time: 03/20/10 12:56:34
Description: ERROR: In ..\..\..\Slicer3\Modules\CommandLineModule\vtkCommandLineModuleLogic.cxx, line 1522
vtkCommandLineModuleLogic (0C13DC38): EMSegment Command-line completed with errors




Type: Error
Time: 03/20/10 12:56:34
Description: ERROR: In ..\..\..\Slicer3\Modules\CommandLineModule\vtkCommandLineModuleLogic.cxx, line 1497
vtkCommandLineModuleLogic (0C13DC38): EMSegment Command-line standard error:

ERROR: no EMSegment parameter nodes in scene.

Errors detetected.  Segmentation failed.





Type: Information
Time: 03/20/10 12:56:25
Description: EMSegment Command-line command line: 

C:/cygwin/home/rao/SLICER~2/lib/Slicer3/Plugins/Debug/EMSegmentCommandLine.exe --mrmlSceneFileName C:/vmtktest/EM/myfiles/Data/EMSegmentTutorialTemplate_ImagesOnly.mrml --resultVolumeFileName C:/segmentation/AutomaticSegmentation/resultlabel/EMtest_label.mhd --targetVolumeFileNames C:/segmentation/AutomaticSegmentation/volumes/target.txt --atlasVolumeFileNames C:/segmentation/AutomaticSegmentation/atlas/atlasvolumes.txt --intermediateResultsDirectory C:/segmentation/AutomaticSegmentation/intermediate_results 


Type: Information
Time: 03/20/10 12:56:25
Description: CommandLineModule

Type: Information
Time: 03/20/10 12:56:24
Description: C:/cygwin/home/rao/SLICER~2/lib/Slicer3/Plugins/Debug/EMSegmentCommandLine.exe

Type: Information
Time: 03/20/10 12:56:24
Description: Found CommandLine Module, target is 



More information about the slicer-users mailing list