[slicer-users] Slicer fails on launch - 3.6 and 3.5 binaries on XP (SIGABRT / CHILDKILLED)

Andras Lasso lasso at cs.queensu.ca
Sat Sep 11 13:25:09 EDT 2010


Hi David,

As the binaries work correctly for others, most likely there are problems
with the shared libraries (DLLs) on your PC. Some DLLs may be invalid and/or
missing.


To diagnose the problem please perform the following steps:

1. Download the dependency walker tool (depends.exe) from Microsoft
(http://www.dependencywalker.com/) and copy depends.exe to the Slicer
installation directory

2. Start depends with the slicer launcher by entering this in the Slicer
installation directory:
    Slicer3.exe --launch depends.exe

3. In dependency walker choose File / Open and select Slicer3-real.exe (in
the bin directory within the Slicer installation directory)

4. In dependency walker choose File / Save as... enter a filename, select
"Comma separated Values (*.csv)" as "Save as type"

5. Send me the saved .csv file so that I can check if there is an invalid or
missing dll


Andras



-----Original Message-----
From: slicer-users-bounces at bwh.harvard.edu
[mailto:slicer-users-bounces at bwh.harvard.edu] On Behalf Of Lanznar, David
Sent: September-10-10 3:24 PM
To: slicer-users at bwh.harvard.edu
Subject: [slicer-users] Slicer fails on launch - 3.6 and 3.5 binaries on XP
(SIGABRT / CHILDKILLED)

Hello:

I have just begun to try Slicer for evaluation.

I've downloaded several versions (binaries) for Windows XP Pro 2002 SP3, but
none will launch successfully.  Installing (default install, after
uninstalling any previous version) and running always produces the following
dialog:

*********************
LAUNCH C:/PROGRA~1/SLICER~1.201/bin/Slicer3-real.exe
Returned with error: child killed
SIGABRT

CHILDKILLED XXXX SIGABRT SIGABRT
**********************
Where XXXX is a 4-digit number that varies (3558, 5764, 3264, 4920...)
 

I've tried the following versions/releases:

Slicer3-3.5-alpha-2010-02-15-win32.exe
Slicer3-3.6-2010-06-10-win32.exe
Slicer3-3.6.1-2010-08-16-win32.exe
Slicer3-3.6.1-2010-08-23-win32.exe

I haven't found any current information on this problem. Something similar
was discussed in this thread in February
(http://massmail.spl.harvard.edu/public-archives/slicer-users/2010/002657.ht
ml)  and I tried the alpha version based on that, but it also fails.  

A similar case was also discussed on a linux version
here:
http://slicer-devel.65872.n3.nabble.com/SIGABRT-problems-td784898.html#a7848
98

I don't see the issue on the buglist
(http://www.na-mic.org/Bug/my_view_page.php)

Any ideas/suggestions would be appreciated.



David Lanznar
Contract Software Developer
Analogic Inc.  
Peabody MA




_______________________________________________
slicer-users mailing list
slicer-users at bwh.harvard.edu
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to slicer-users-request at massmail.spl.harvard.edu
with unsubscribe as the subject




More information about the slicer-users mailing list