[slicer-users] Conflicting library paths?

Peter A. Gustafson peter.gustafson at wmich.edu
Sun Sep 26 21:11:55 EDT 2010


Hi,

I'm running on gentoo and it appears there are conflicting libraries
that are causing problems.  I downloaded the binary slicer 3.6.1.

When I run I get an error message which appears to indicate that it is
trying to load the system libitcl3.4 instead of the provided libitcl3.2.
 On the other hand, it appears to use the provided tcl8.4 instead of the
system tcl8.5.

Is my interpretation correct and how would I prevent this?

Thanks,

The error message is below.

$ ./Slicer3
Error: version conflict for package "Tcl": have 8.4, need 8.5
while executing:
package require Itcl;

version conflict for package "Tcl": have 8.4, need 8.5
    while executing
"load /usr/lib64/itcl3.4/libitcl3.4.so Itcl"
    ("package ifneeded" script)
    invoked from within
"package require Itcl"Error: slicer requires the Itcl package (package
require Itcl;)

Launch
/home/pete/software/Slicer3-3.6.1-2010-08-23-linux-x86_64/bin/Slicer3-real
returned with error: child process exited abnormally





More information about the slicer-users mailing list