[slicer-users] Slicer 3.6 build problems

Dominique Belhachemi domibel at debian.org
Wed Dec 8 13:59:13 EST 2010


Hi Anthony,

I do recognize this error message. In my case on WinXP with VS9 2008 it
was related to a numpy issue.

All I had to do was turning PYTHON off.

   Slicer3_USE_PYTHON:BOOL=OFF

Because of so many different Windows versions and compiler versions the
error message might be caused by another issue. In this case the
following page might be helpful.
http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions#getbuildtest_on_Windows

Dominique


On Wed, 2010-12-08 at 17:13 +0000, Kilburg, Anthony T wrote:
> I am trying to build Slicer3 in my Windows Vista platform.  I would
> like to use this along with ITK to apply filters to some of my CT
> images.  I’m currently have trouble building Slicer3 and have been
> getting this error:
>  
> Slicer3_BUILD:win32
> CMake Error at CMakeLists.txt:230 (FIND_PACKAGE):
>      Could not find module FindKWWidgets.cmake or a configuration file
> for
>      package KWWidgets.
> 
>     Adjust CMAKE_MODULE_PATH to find FindKWWidgets.cmake or set
> KWWidgets_DIR
>      to the directory containing a CMake configuration file for
> KWWidgets. The
>      file will have one of the following names:
>  
>           KWWidgetsConfig.cmake
>           kwwidgets-config.cmake
>  
> CMake Error at CMakeLists.txt:232 (MESSAGE):
>      Need KWWidgets to build
> 
> Do you recognize this problem and/or know how to resolve it?  I’m
> assuming that I haven’t provided  enough information so please let me
> know what more you may need to know.
> 
>  
> 
> Thank you
> 
> 
> 
> 
> _______________________________________________
> slicer-users mailing list
> slicer-users at bwh.harvard.edu
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to slicer-users-request at massmail.spl.harvard.edu with unsubscribe as the subject





More information about the slicer-users mailing list